[Solved] ERROR: phpize failed, command not found in PECL

If you are installing PHP extensions using PECL, you might end up with an error

pecl install uploadprogress
 
WARNING: channel "pecl.php.net" has updated its protocols, use "pecl channel-update pecl.php.net" to update
downloading uploadprogress-1.0.3.1.tgz ...
Starting to download uploadprogress-1.0.3.1.tgz (9,040 bytes)
....done: 9,040 bytes
4 source files, building
running: phpize
sh: phpize: command not found
ERROR: `phpize' failed

Solution:

The error clearly indicates that issue with phpize. This requires a php-devel to work as phpize is included in php-devel.

Just install php-devel package using yum.

yum -y install php-devel

Then try installing PHP extension again using PECL which should work fine.

Hope this helps!

Share on Facebook5
Share on Google+6Tweet about this on TwitterShare on StumbleUpon0Share on LinkedIn0Share on Tumblr0Digg thisPin on Pinterest0Share on Reddit0Email this to someonePrint this page

About Abhijit Sandhan

Abhijit Sandhan
Loves Linux, Blogging, Traveling, Hiking and sharing knowledge!

Leave a Reply

Your email address will not be published. Required fields are marked *

CAPTCHA