Networking & Security

[Fixed] Zentyal 3.5 NO_PUBKEY error in apt-get update

zentyal logo

Zentyal community edition is one of the widely used application for managing infrastructure. Zentyal pushes frequent updates through Zentyal repositories. One my get following error while upgrading Zentyal: W: GPG error: http://archive.zentyal.org 3.5 Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 8E9229F7E23F4777 Solution: Add the Zentyal 3.5 key so that apt connect to …

Read More »

[How To] Disable SSLv3 for Apache in WHM cPanel

apache logo

After HeartBleed, Poodle (Padding Oracle On Downgraded Legacy Encryption) is another exploit recently discovered affecting SSL version3. To disable SSL version 3 for Apache in WHM cPanel, you can follow below steps: 1) Login in WHM and go to Service Configuration > Apache Configuration > Include Editor 2) Click on the Pre Main Include and select All Versions option from …

Read More »

[How to ] Fix OpenSSL for Heartbleed Vulnerability

openssl heartbleed image

As you are all aware of the latest OpenSSL vulnerability termed as "Heartbleed", many blogs are providing information what it is and how does it affects. I am going to focus on fixing the OpenSSL Heartbleed vulnerability in this post. Which OpenSSL versions are affected? The OpenSSL version 1.0.1 is vulnerable except version 1.0.1g. Other versions like 1.0.0, 0.9.x are …

Read More »

LFD Excessive Resource Usage Alerts

Linux logo

The LFD service sometimes send excessive resource usage alerts as below: Time: Tue Nov 19 09:41:10 2013 +0530 Account: xxxxxx Resource: Virtual Memory Size Exceeded: 205 > 200 (MB) Executable: /usr/bin/php Command Line: /usr/bin/php /home/xxxxxx/public_html/index.php PID: 24933 (Parent PID:22578) Killed: No The above alerts are received when a process utilizes more than the memory defined in the CSF configuration file …

Read More »

Modsecurity rule execution error - PCRE limits exceeded

Linux logo

If you are getting following mod_security error in the Apache error logs [Mon Jun 11 16:54:50 2011] [error] [client 171.235.170.226] ModSecurity: Rule 8269d10 [id "-"][file "/usr/local/apache/conf/modsec2.user.conf"][line "763"] - Execution error - PCRE limits exceeded (-8): (null). [hostname "www.example.com"] [uri "/wp-content/themes/daily/timthumb.php"] [unique_id "T9YUytXlXKcADxXq-WUAAAAg"] then to get rid of the error you will have to make some server side changes as the …

Read More »